Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).
Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
Output
* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
Sample Input
4 6
1 4
2 6
3 12
2 7
Sample Output
23
Solutions:
For a typical knapsack problem, you want to set a template directly dp[3402][12880] at first, but later you find that the memory is obviously out of limit. In order to save memory and process a group of data for each input, you only need dp[2][12880]. Layer 0 is used to store a group of results, layer 1 is used to store the results of the current group, and you can update layer 0 constantly. In this way, although memory is saved, it is relatively slow. 360ms is used, so time and space cannot be combined.
#include<stdio.h>
int dp[2][12885]={0};
int main()
{
int n,m,w,v;
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
{
scanf("%d%d",&w,&v);
for(int j=1;j<=m;j++)
{
if(w<=j)
{
if(dp[0][j-w]+v>dp[0][j])dp[1][j]=dp[0][j-w]+v;
else dp[1][j]=dp[0][j];
}
else dp[1][j]=dp[0][j];
}
for(int j=1;j<=m;j++)
{
dp[0][j]=dp[1][j];
}
}
printf("%d\n",dp[1][m]);
}