Catalog
Experimental topology
Experiment steps and configuration
ip configuration
RA
#
sysname RA
#
interface GigabitEthernet0/0/0
ip address 10.1.1.1 255.255.255.0
#
RB
#
sysname RB
#
interface GigabitEthernet0/0/0
ip address 10.1.1.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 10.1.2.1 255.255.255.0
#
RC
#
sysname RC
#
interface GigabitEthernet0/0/0
ip address 10.1.2.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 10.1.3.1 255.255.255.0
#
RD
#
sysname RD
#
interface GigabitEthernet0/0/0
ip address 10.1.3.2 255.255.255.0
#
Configure ospf and loopback address
RA
#
router id 1.1.1.1
#
interface LoopBack0
ip address 1.1.1.1 255.255.255.255
#
ospf 1
area 0.0.0.1
network 1.1.1.1 0.0.0.0
network 10.1.1.1 0.0.0.0
#
RB
#
router id 2.2.2.2
#
interface LoopBack0
ip address 2.2.2.2 255.255.255.255
#
ospf 1
area 0.0.0.0
network 2.2.2.2 0.0.0.0
network 10.1.2.1 0.0.0.0
area 0.0.0.1
network 10.1.1.2 0.0.0.0
#
RC
#
router id 3.3.3.3
#
interface LoopBack0
ip address 3.3.3.3 255.255.255.255
#
ospf 1
area 0.0.0.0
network 3.3.3.3 0.0.0.0
network 10.1.2.2 0.0.0.0
area 0.0.0.2
network 10.1.3.1 0.0.0.0
#
RD
#
router id 4.4.4.4
#
interface LoopBack0
ip address 4.4.4.4 255.255.255.255
#
ospf 1
area 0.0.0.2
network 4.4.4.4 0.0.0.0
network 10.1.3.2 0.0.0.0
#
experimental result
Test whether RA-RD passes
Change of relationship between RA-RB detected by packet capturing
- A. B sends hello messages to each other to find neighbors. The relationship changes: down - init - two way;
Then DR and BDR are selected through DD message, and then A and B send their lsdb profiles to the other party through DD message in EXCHANGE state. The relationship between A and B: two-way -- EXSTART -- EXCHANGE,
Then A and B send lsq and lsu messages in the loading state, and finally send lsack messages in the full state after receiving. The relationship between A and B: EXCHANGE - loading - full. - In two-way, neighbor relationship is established; in full, neighbor relationship is established; ospf is successful only when neighbor relationship is established.