Configuration exercise for dynamic routing RIP

Posted by justinma on Thu, 06 Jan 2022 18:24:18 +0100

Example:

Requirement:

R1-R2-R3-R4-R5 runs RIPV2, R6-R7 runs RIPV1
1. Use reasonable addresses to plan the network and create loopback interfaces for each
2, R1 Create Loop 172.16.1.1/24 172.16.2.1/24 172.16.3.1/24
3, requiring R3 to access R1 loops using R2
4. Reduce the number of routing entries and increase routing delivery security
5, R5 create a loopback analog operator, cannot announce
6, R1 telnet_R2 loops back to actual telnet on R7
7, R6-R7 routers cannot learn to reach the R1 loop route
8, full network access

Analysis:

1 R1-R2-R3-R4-R5 runs RIPV2, R6-R7 runs RIPV1 -- two versions of RIP 1/2

(2) Plan the network with reasonable addresses and create loopback interfaces for each router - each router has its own loopback interface (no IP restriction)

(3) r1 has three loops - Manual summary + announcement is required

(4) Require R3 to use R2 to access R1 loops - setting COST makes 1-4-3 expensive and 1-2-3 expensive

Reduce the number of routing entries, increase routing delivery security - manual summary!!! Don't forget the empty interface!!! Required Settings Authenticate Logon

R5 creates a loopback analog operator and cannot declare it ---***R5's loopback cannot declare it as nat Technology

R1 telnet_R2 Loop Actual telnet to R7 - More complex

#You need to ensure that the cost between a. R2 reaching R7 and R2 reaching R1 is minimal!!!

The telent set by b.R2 is port R7!!! And is the loop of R2

Make sure R2 and R7 learn from ea c h other

The R6-R7 router cannot learn to reach the R1 loop by setting up acl to ensure that R1 traffic is refused to flow into R6

Network-wide access - set default routes!!! Attention Ring Protection

1. Basic Configuration (Interface, Loop Configuration)

//R1 interface and three loops
[R1]interface g0/0/0
[R1-GigabitEthernet0/0/0]ip address 1.0.0.1 30
[R1-GigabitEthernet0/0/0]interface g0/0/1
[R1-GigabitEthernet0/0/1]ip address 4.0.0.1 30
[R1-GigabitEthernet0/0/1]interface l 0
[R1-LoopBack0]ip address  172.16.1.1 24
[R1-LoopBack0]interface l 1
[R1-LoopBack1]ip address 172.16.2.1 24
[R1-LoopBack1]interface l 2
[R1-LoopBack2]ip address 172.16.3.1 24

//R2 interface and a single loop
[R2]interface  g0/0/0
[R2-GigabitEthernet0/0/1]interface g0/0/0
[R2-GigabitEthernet0/0/0]ip address  1.0.0.2 30
[R2-GigabitEthernet0/0/0]interface g0/0/1
[R2-GigabitEthernet0/0/1]ip address 2.0.0.1 30
[R2-GigabitEthernet0/0/1]interface  l 0
[R2-LoopBack0]ip address 192.168.2.1 24

//R3 interface and a single loop
[R3]interface g0/00/0
[R3-GigabitEthernet0/0/0]ip ad	
[R3-GigabitEthernet0/0/0]ip address 2.0.0.2 30
[R3-GigabitEthernet0/0/0]interface g0/00/1
[R3-GigabitEthernet0/0/1]ip address 3.0.0.1 30
[R3-GigabitEthernet0/0/1]interface l 0
[R3-LoopBack0]ip address 192.168.3.1 24

//R4 Four interfaces and a single loop - need to extend one interface
[R4]interface  g0/0/0
[R4-GigabitEthernet0/0/0]ip address 4.0.0.2 30
[R4-GigabitEthernet0/0/0]interface g0/0/1
[R4-GigabitEthernet0/0/1]ip address 3.0.0.2 30
[R4-GigabitEthernet0/0/1]interface g0/0/2
[R4-GigabitEthernet0/0/2]ip address 5.0.0.1 30
[R4-GigabitEthernet0/0/2]interface g4/0/0
[R4-GigabitEthernet4/0/0]ip address 6.0.0.1 30
[R4-GigabitEthernet4/0/0]interface l 0
[R4-LoopBack0]ip address 192.168.4.1 24

//ISP interfaces and loops
[ISP]interface g0/0/0
[ISP-GigabitEthernet0/0/0]ip ad	
[ISP-GigabitEthernet0/0/0]ip address 5.0.0.2 30
[ISP-GigabitEthernet0/0/0]interface l 0
[ISP-LoopBack0]ip address 192.168.5.1 24

//R6 interface and a single loop
[R6]interface g0/0/0
[R6-GigabitEthernet0/0/0]ip address  6.0.0.2 30
[R6-GigabitEthernet0/0/0]interface g0/0/1
[R6-GigabitEthernet0/0/1]ip address 7.0.0.1 30
[R6-GigabitEthernet0/0/1]interface l 0
[R6-LoopBack0]ip ad	
[R6-LoopBack0]ip address 192.168.6.1 24

//R7 interface and a single loop
[R7]interface  g0/00/0
[R7-GigabitEthernet0/0/0]ip ad	
[R7-GigabitEthernet0/0/0]ip address  7.0.0.2 30
[R7-GigabitEthernet0/0/0]interface l 0
[R7-LoopBack0]ip address 192.168.7.1 24

2. Configure RIP (need to distinguish v1 from v2)

//RIPV1
//R1
[R1]rip
[R1-rip-1]version 2
[R1-rip-1]net	
[R1-rip-1]network 172.16.0.0
[R1-rip-1]network 1.0.0.0
[R1-rip-1]network 4.0.0.0

//R2
[R2]rip
[R2-rip-1]version 2
[R2-rip-1]network 192.168.2.0
[R2-rip-1]network 1.0.0.0
[R2-rip-1]network 2.0.0.0

//R3
[R3]rip
[R3-rip-1]version 2
[R3-rip-1]network 192.168.3.0
[R3-rip-1]network 2.0.0.0
[R3-rip-1]network 3.0.0.0

//R4
[R4-rip-1]version 2	
[R4-rip-1]network  192.168.4.0
[R4-rip-1]network  5.0.0.0
[R4-rip-1]network 3.0.0.0
[R4-rip-1]network 4.0.0.0
[R4-rip-1]network 6.0.0.0

//Do not declare loopback
//ISP
[ISP]rip 
[ISP-rip-1]version 2
[ISP-rip-1]network  5.0.0.0

#RIP V1
//R6
[R6]rip
[R6-rip-1]ne	
[R6-rip-1]network 6.0.0.0
[R6-rip-1]network 7.0.0.0
[R6-rip-1]network 192.168.6.0

//R7
[R7]rip
[R7-rip-1]ne	
[R7-rip-1]network 7.0.0.0
[R7-rip-1]network 192.168.7.0

3. Configuration checks (to prevent losses and failures)

//R1 and its RIP routing table
[R1-rip-1]display this 
[V200R003C00]
#
rip 1
 version 2
 network 172.16.0.0
 network 1.0.0.0
 network 4.0.0.0
#
return
//RIP Routing Table
[R1]display ip routing-table protocol  rip 
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Public routing table : RIP
         Destinations : 7        Routes : 7        

RIP routing table status : <Active>
         Destinations : 7        Routes : 7

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        2.0.0.0/30  RIP     100  1           D   1.0.0.2         GigabitEthernet
0/0/0
        3.0.0.0/30  RIP     100  2           D   1.0.0.2         GigabitEthernet
0/0/0
        5.0.0.0/30  RIP     100  3           D   1.0.0.2         GigabitEthernet
0/0/0
        6.0.0.0/30  RIP     100  3           D   1.0.0.2         GigabitEthernet
0/0/0
    192.168.2.0/24  RIP     100  1           D   1.0.0.2         GigabitEthernet
0/0/0
    192.168.3.0/24  RIP     100  2           D   1.0.0.2         GigabitEthernet
0/0/0
    192.168.4.0/24  RIP     100  3           D   1.0.0.2         GigabitEthernet
0/0/0

RIP routing table status : <Inactive>
         Destinations : 0        Routes : 0


//R7 and its routing table
[R7-rip-1]display this
[V200R003C00]
#
rip 1
 version 1
 network 7.0.0.0
 network 192.168.7.0
#
return

//RIP Routing Table for R7
[R7-rip-1]display ip routing-table protocol rip
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Public routing table : RIP
         Destinations : 2        Routes : 2        

RIP routing table status : <Active>
         Destinations : 2        Routes : 2

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        6.0.0.0/8   RIP     100  1           D   7.0.0.1         GigabitEthernet
0/0/0
    192.168.6.0/24  RIP     100  1           D   7.0.0.1         GigabitEthernet
0/0/0

RIP routing table status : <Inactive>
         Destinations : 0        Routes : 0

//R4 and its RIP routing table
[R4-rip-1]display this 
[V200R003C00]
#
rip 1
 version 2
 network 192.168.4.0
 network 5.0.0.0
 network 3.0.0.0
 network 4.0.0.0
 network 6.0.0.0
#
return

//RIP Routing Table
[R4-rip-1]display ip routing-table protocol  rip 
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Public routing table : RIP
         Destinations : 7        Routes : 7        

RIP routing table status : <Active>
         Destinations : 7        Routes : 7

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        1.0.0.0/30  RIP     100  2           D   3.0.0.1         GigabitEthernet
0/0/1
        2.0.0.0/30  RIP     100  1           D   3.0.0.1         GigabitEthernet
0/0/1
     172.16.1.0/24  RIP     100  3           D   3.0.0.1         GigabitEthernet
0/0/1
     172.16.2.0/24  RIP     100  3           D   3.0.0.1         GigabitEthernet
0/0/1
     172.16.3.0/24  RIP     100  3           D   3.0.0.1         GigabitEthernet
0/0/1
    192.168.2.0/24  RIP     100  2           D   3.0.0.1         GigabitEthernet
0/0/1
    192.168.3.0/24  RIP     100  1           D   3.0.0.1         GigabitEthernet
0/0/1

RIP routing table status : <Inactive>
         Destinations : 0        Routes : 0

Five, route summary (watch out for loops!!!)

//Need to be set on both interfaces
[R1]interface g0/0/0
[R1-GigabitEthernet0/0/0]rip summary-address 172.16.0.0 255.255.252.0
[R1-GigabitEthernet0/0/0]interface g0/0/1
[R1-GigabitEthernet0/0/1]rip summary-address 172.16.0.0 255.255.252.0
[R1]ip route-static 172.16.0.0 22 NULL 0

Sixth, Configure Routing ACL (1-2-3)

//Select to set the capture R1 data on R3 
[R3]acl 2000
[R3-acl-basic-2000]rule permit source 172.16.0.0  0

//View configurations carefully
[R3-acl-basic-2000]display this 
[V200R003C00]
#
acl number 2000  
 rule 5 permit source 172.16.0.0 0 
#
return
[R3-acl-basic-2000]q

//Configure Input Interface to Increase Cost -- In case, I set 1-2-3 to cost+2-4-3 to cost+5
[R3]interface g0/0/1
[R3-GigabitEthernet0/0/1]rip metricin 2000 5 
[R3]interface g0/0/0
[R3-GigabitEthernet0/0/0]rip metricin 2000 2

//inspect
[R3-GigabitEthernet0/0/0]display ip routing-table protocol rip
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Public routing table : RIP
         Destinations : 7        Routes : 7        

RIP routing table status : <Active>
         Destinations : 7        Routes : 7

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        1.0.0.0/30  RIP     100  1           D   2.0.0.1         GigabitEthernet
0/0/0
        4.0.0.0/30  RIP     100  1           D   3.0.0.2         GigabitEthernet
0/0/1
        5.0.0.0/30  RIP     100  1           D   3.0.0.2         GigabitEthernet
0/0/1
        6.0.0.0/30  RIP     100  1           D   3.0.0.2         GigabitEthernet
0/0/1
     172.16.0.0/22  RIP     100  4           D   2.0.0.1         GigabitEthernet
0/0/0
    192.168.2.0/24  RIP     100  1           D   2.0.0.1         GigabitEthernet
0/0/0
    192.168.4.0/24  RIP     100  1           D   3.0.0.2         GigabitEthernet
0/0/1

RIP routing table status : <Inactive>
         Destinations : 0        Routes : 0

//cost of 1-2-3 is 2+2 ---4 at this time

Seven, set telent mapping for R1 1

//First, make sure R2 can telentR7

//I chose to set R6's input interface to version2
[R6]interface g0/0/0
[R6-GigabitEthernet0/0/0]rip version  2
[R6-GigabitEthernet0/0/0]q

//At this point R6 also starts refreshing the route of V2
[R6]display  ip routing-table protocol  rip 
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Public routing table : RIP
         Destinations : 10       Routes : 10       

RIP routing table status : <Active>
         Destinations : 10       Routes : 10

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        1.0.0.0/30  RIP     100  3           D   6.0.0.1         GigabitEthernet
0/0/0
        2.0.0.0/30  RIP     100  2           D   6.0.0.1         GigabitEthernet
0/0/0
        3.0.0.0/30  RIP     100  1           D   6.0.0.1         GigabitEthernet
0/0/0
        4.0.0.0/30  RIP     100  1           D   6.0.0.1         GigabitEthernet
0/0/0
        5.0.0.0/30  RIP     100  1           D   6.0.0.1         GigabitEthernet
0/0/0
     172.16.0.0/22  RIP     100  6           D   6.0.0.1         GigabitEthernet
0/0/0
    192.168.2.0/24  RIP     100  3           D   6.0.0.1         GigabitEthernet
0/0/0
    192.168.3.0/24  RIP     100  2           D   6.0.0.1         GigabitEthernet
0/0/0
    192.168.4.0/24  RIP     100  1           D   6.0.0.1         GigabitEthernet
0/0/0
    192.168.7.0/24  RIP     100  1           D   7.0.0.2         GigabitEthernet
0/0/1

RIP routing table status : <Inactive>
         Destinations : 0        Routes : 0

//Just in case, I also checked on R7
[R7]display ip routing-table protocol  rip 
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Public routing table : RIP
         Destinations : 11       Routes : 11       

RIP routing table status : <Active>
         Destinations : 11       Routes : 11

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        1.0.0.0/8   RIP     100  4           D   7.0.0.1         GigabitEthernet
0/0/0
        2.0.0.0/8   RIP     100  3           D   7.0.0.1         GigabitEthernet
0/0/0
        3.0.0.0/8   RIP     100  2           D   7.0.0.1         GigabitEthernet
0/0/0
        4.0.0.0/8   RIP     100  2           D   7.0.0.1         GigabitEthernet
0/0/0
        5.0.0.0/8   RIP     100  2           D   7.0.0.1         GigabitEthernet
0/0/0
        6.0.0.0/8   RIP     100  1           D   7.0.0.1         GigabitEthernet
0/0/0
     172.16.0.0/16  RIP     100  7           D   7.0.0.1         GigabitEthernet
0/0/0
    192.168.2.0/24  RIP     100  4           D   7.0.0.1         GigabitEthernet
0/0/0
    192.168.3.0/24  RIP     100  3           D   7.0.0.1         GigabitEthernet
0/0/0
    192.168.4.0/24  RIP     100  2           D   7.0.0.1         GigabitEthernet
0/0/0
    192.168.6.0/24  RIP     100  1           D   7.0.0.1         GigabitEthernet
0/0/0

RIP routing table status : <Inactive>
         Destinations : 0        Routes : 0

//Try pingR7 on R2 --ok
[R2]ping 7.0.0.2
  PING 7.0.0.2: 56  data bytes, press CTRL_C to break
    Reply from 7.0.0.2: bytes=56 Sequence=1 ttl=252 time=40 ms
    Reply from 7.0.0.2: bytes=56 Sequence=2 ttl=252 time=30 ms
    Reply from 7.0.0.2: bytes=56 Sequence=3 ttl=252 time=40 ms
    Reply from 7.0.0.2: bytes=56 Sequence=4 ttl=252 time=50 ms
    Reply from 7.0.0.2: bytes=56 Sequence=5 ttl=252 time=40 ms

  --- 7.0.0.2 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 30/40/50 ms

Seven, set telent mapping for R1 2

//To ensure that R2 has the smallest cost to R7 and R7 has the smallest cost to R1
//Ensuring R2 is the way to go!!!
// 2*-3-4-5-6-7    7-6-5-4-3-2*-1

//I set the route cost+10 to R1 on R4--hard dot
[R4]acl 2000

//Grab R7's Return Flow
[R4-acl-basic-2000]rule permit source 7.0.0.0 0
[R4-acl-basic-2000]q
[R4]interface g0/0/0
[R4-GigabitEthernet0/0/0]rip metricout 2000 10

//Now go to the rip table for R4
//The cost to 172.16.0.0/22 is 5, and it's 3.0.0.1#so the cost ahead needs to be harder.
[R4]display ip routing-table protocol  rip 
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Public routing table : RIP
         Destinations : 8        Routes : 8        

RIP routing table status : <Active>
         Destinations : 8        Routes : 8

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        1.0.0.0/30  RIP     100  2           D   3.0.0.1         GigabitEthernet
0/0/1
        2.0.0.0/30  RIP     100  1           D   3.0.0.1         GigabitEthernet
0/0/1
        7.0.0.0/30  RIP     100  1           D   6.0.0.2         GigabitEthernet
4/0/0
     172.16.0.0/22  RIP     100  5           D   3.0.0.1         GigabitEthernet
0/0/1
    192.168.2.0/24  RIP     100  2           D   3.0.0.1         GigabitEthernet
0/0/1
    192.168.3.0/24  RIP     100  1           D   3.0.0.1         GigabitEthernet
0/0/1
    192.168.6.0/24  RIP     100  1           D   6.0.0.2         GigabitEthernet
4/0/0
    192.168.7.0/24  RIP     100  2           D   6.0.0.2         GigabitEthernet
4/0/0

RIP routing table status : <Inactive>
         Destinations : 0        Routes : 0

Seven, set telent mapping for R1 3

//Major Authentication#User is lxb password is 123 456 ciphertext

[R7]user-interface vty  0 4
[R7-ui-vty0-4]authentication-mode aaa
[R7-ui-vty0-4]q
[R7]aaa
[R7-aaa]local-user lxb privilege level 15 password cipher 123456
Info: Add a new user.

//Check, just in case
[R7-aaa]display  this 
[V200R003C00]
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user lxb password cipher %$%$epUpT4#e("xqEmQl1GiARD5$%$%$
 local-user lxb privilege level 15
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
return

//Then map the interface to R2#This is a port mapping
[R2-GigabitEthernet0/0/0]nat server protocol tcp global current-interface 23 ins
ide 7.0.0.2 23
Warning:The port 23 is well-known port. If you continue it may cause function fa
ilure.
Are you sure to continue?[Y/N]:y

//inspect
[R2-GigabitEthernet0/0/0]display this 
[V200R003C00]
#
interface GigabitEthernet0/0/0
 ip address 1.0.0.2 255.255.255.252 
 nat server protocol tcp global current-interface telnet inside 7.0.0.2 23
#
return

        #This side is a bit fussy. I have a few problems. I will summarize them later.

8. Setting up nat Technology

//As we all know, traffic is reciprocal, so I set a static default to pass through the R4 interface
[ISP]ip route-static   0.0.0.0 0 5.0.0.1  

//Then you configure default and ACL policies on R4

//default
[R4]ip route-static 0.0.0.0 0 5.0.0.2
[R4]return
[R4]rip 
[R4-rip-1]default-route originate 

//nat policy
[R4]nat address-group 1 192.168.5.10 192.168.5.20
[R4]acl 2002
[R4-acl-basic-2002]rule permit source any 
[R4-acl-basic-2002]q
[R4]interface g0/0/2
[R4-GigabitEthernet0/0/2]nat outbound 2002 address-group 1 
[R4-GigabitEthernet0/0/2]q
        #There's a fucking thing going on here, Mark 2

9. Configuration R1 cannot be learned by R6 and R7

[R6]acl 2000
[R6-acl-basic-2000]rule 5 deny source 172.16.0.0 0 
[R6-acl-basic-2000]display this 
[V200R003C00]
#
acl number 2000  
 rule 5 deny source 172.16.0.0 0 
#
return
[R6-acl-basic-2000]rule permit source any 
[R6-rip-1]filter-policy 2000 import
    #Looking at my operation here, I am a bit fucked. There was a problem. Mark 3

//Refresh on Routing Table to R6 and R7 at this time
[R6]display ip routing-table protocol rip
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Public routing table : RIP
         Destinations : 10       Routes : 10       

RIP routing table status : <Active>
         Destinations : 10       Routes : 10

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        0.0.0.0/0   RIP     100  1           D   6.0.0.1         GigabitEthernet
0/0/0
        1.0.0.0/30  RIP     100  3           D   6.0.0.1         GigabitEthernet
0/0/0
        2.0.0.0/30  RIP     100  2           D   6.0.0.1         GigabitEthernet
0/0/0
        3.0.0.0/30  RIP     100  1           D   6.0.0.1         GigabitEthernet
0/0/0
        4.0.0.0/30  RIP     100  1           D   6.0.0.1         GigabitEthernet
0/0/0
        5.0.0.0/30  RIP     100  1           D   6.0.0.1         GigabitEthernet
0/0/0
    192.168.2.0/24  RIP     100  3           D   6.0.0.1         GigabitEthernet
0/0/0
    192.168.3.0/24  RIP     100  2           D   6.0.0.1         GigabitEthernet
0/0/0
    192.168.4.0/24  RIP     100  1           D   6.0.0.1         GigabitEthernet
0/0/0
    192.168.7.0/24  RIP     100  1           D   7.0.0.2         GigabitEthernet
0/0/1

RIP routing table status : <Inactive>
         Destinations : 0        Routes : 0

<R7>display ip routing-table protocol rip
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Public routing table : RIP
         Destinations : 11       Routes : 11       

RIP routing table status : <Active>
         Destinations : 11       Routes : 11

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        0.0.0.0/0   RIP     100  2           D   7.0.0.1         GigabitEthernet
0/0/0
        1.0.0.0/8   RIP     100  4           D   7.0.0.1         GigabitEthernet
0/0/0
        2.0.0.0/8   RIP     100  3           D   7.0.0.1         GigabitEthernet
0/0/0
        3.0.0.0/8   RIP     100  2           D   7.0.0.1         GigabitEthernet
0/0/0
        4.0.0.0/8   RIP     100  2           D   7.0.0.1         GigabitEthernet
0/0/0
        5.0.0.0/8   RIP     100  2           D   7.0.0.1         GigabitEthernet
0/0/0
        6.0.0.0/8   RIP     100  1           D   7.0.0.1         GigabitEthernet
0/0/0
    192.168.2.0/24  RIP     100  4           D   7.0.0.1         GigabitEthernet
0/0/0
    192.168.3.0/24  RIP     100  3           D   7.0.0.1         GigabitEthernet
0/0/0
    192.168.4.0/24  RIP     100  2           D   7.0.0.1         GigabitEthernet
0/0/0
    192.168.6.0/24  RIP     100  1           D   7.0.0.1         GigabitEthernet
0/0/0

RIP routing table status : <Inactive>
         Destinations : 0        Routes : 0

//The 172.16.0.0/22 routing information is lost at this time

Ten, verification

//So long to configure, when checking results

//R1ping R7
<R1>ping 192.168.7.1
  PING 192.168.7.1: 56  data bytes, press CTRL_C to break
    Reply from 192.168.7.1: bytes=56 Sequence=1 ttl=251 time=70 ms
    Reply from 192.168.7.1: bytes=56 Sequence=2 ttl=251 time=40 ms
    Reply from 192.168.7.1: bytes=56 Sequence=3 ttl=251 time=60 ms
    Reply from 192.168.7.1: bytes=56 Sequence=4 ttl=251 time=50 ms
    Reply from 192.168.7.1: bytes=56 Sequence=5 ttl=251 time=40 ms

//R4 ping External Network
<R4>ping 192.168.5.1
  PING 192.168.5.1: 56  data bytes, press CTRL_C to break
    Reply from 192.168.5.1: bytes=56 Sequence=1 ttl=255 time=20 ms
    Reply from 192.168.5.1: bytes=56 Sequence=2 ttl=255 time=10 ms
    Reply from 192.168.5.1: bytes=56 Sequence=3 ttl=255 time=20 ms
    Reply from 192.168.5.1: bytes=56 Sequence=4 ttl=255 time=30 ms
    Reply from 192.168.5.1: bytes=56 Sequence=5 ttl=255 time=20 ms

  --- 192.168.5.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 10/20/30 ms

//R1telent R2
<R1>telnet 192.168.2.2
  Press CTRL_] to quit telnet mode
  Trying 192.168.2.2 ...
  Connected to 192.168.2.2 ...

Login authentication


Username:lxb
Password:
  ----------------------------------------------------------------------------- 
    
  User last login information:     
  -----------------------------------------------------------------------------
  Access Type: Telnet      
  IP-Address : 7.0.0.1     
  Time       : 2022-01-06 22:54:38-08:00     
  -----------------------------------------------------------------------------
<R7>
<R7>q

//Basic Completion Requirements

Summary of issues:

(1) Three configuration issues:

①do R2 When I configure port mapping for R2 Of g0/0/0 Configuration of the interface, but requires R2 Loops of
    Configuration Question: I am telent When looping back, 192 was found.168.2.1 Not available, and then modified with help
    Reason: Huawei's ENSP There will be loopback failures ping through(Virtual Address)
<R1>ping 192.168.2.1
  PING 192.168.2.1: 56  data bytes, press CTRL_C to break
    Reply from 192.168.2.1: bytes=56 Sequence=1 ttl=255 time=20 ms
    Reply from 192.168.2.1: bytes=56 Sequence=2 ttl=255 time=20 ms
    Reply from 192.168.2.1: bytes=56 Sequence=3 ttl=255 time=40 ms
    Reply from 192.168.2.1: bytes=56 Sequence=4 ttl=255 time=30 ms
    Reply from 192.168.2.1: bytes=56 Sequence=5 ttl=255 time=20 ms

  --- 192.168.2.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 20/26/40 ms

<R1>ping 192.168.2.2
  PING 192.168.2.2: 56  data bytes, press CTRL_C to break
    Request time out
    Request time out
    Request time out
    Request time out

  --- 192.168.2.2 ping statistics ---
    4 packet(s) transmitted
    0 packet(s) received
    100.00% packet loss
    Also, when configuring, it's the destination address and the corresponding port. I'm writing this as a mask. -- Palm and mouth
 # Nat server protocol TCP global current-interface telnet in 7.0.0.2 30 error
 # Nat server protocol TCP global 192.168.2.2 telnet in 7.0.0.2 telnet is correct

②In progress nat At announcement time, I did not set default and ISP Static routing of, resulting in persistent packet loss
    Later, with help, I wrote ISP Static Routing for

③This is the most silent question I'm setting up to reject deny ACL No direction allowed was set for policy permit
    Cause me R6 and R7 Always unable to refresh!!!

(2) Problems in the experiment:

1.When configuring announcements
 Huawei ENSP Default RIP yes version1
 I am configuring that is, forced use V1,And when configuring it, it was adjusted to V2 Mode, so cause R6/R7 Unable to brush properly RIP information

Solution:
stay R6 Access interface for G0/0/0 Set Up rip version  2 Success

2.To configure nat At that time, I always thought dynamic routing was undeclared ISP,Acquire by default only isp Segment Information
 But!!! Need to isp Set a static route inside, otherwise no return packet information can be generated

3.Error in configuring announcement ip
 Causes an old one to persist ip Can't be brushed off, solution: undo Then announce it again

4.do telent Question, loopback question!!!

5.about RIP Boundary problems
 I thought RIPV1 and RIPV2 Is two zones, two default routes need to be set at the same time to get nat Web Segments
  ---> No distinction RIP Boundary and nat Boundary Routing --- Two concepts are different!!!

Complete!

Topics: network Network Protocol